Continuity 6 Software Prerequisites

All Platforms

  • The user must have write access to the directory where Continuity is installed.

Windows XP, Windows 7, and Windows 8

  • If your system is missing python 2.7 the installer should install it for you. If (for whatever reason) the installer fails to do this, please install it from here.

  • Additionally, if the installation of PyWin32 fails, you can install that from here. This must be installed after installing Python.

  • If you install python 2.7 somewhere other than C:/Python27/, you must set the environment variable CONTPYTHON to this location. If you don't know how to do this, see here. Alternatively you can add your python directory to your PATH environment variable if it's your only python installation.

  • If you will want to compile models within Continuity, please see: Compiling Models


  • gzip unarchiving tool for linux (If installing from tar file)
  • If Continuity fails to start with an error like this:
    •        X Error of failed request: BadWindow (invalid Window parameter)
               Major opcode of failed request: 3 (X_GetWindowAttributes) 
      You may need to install the latest graphics drivers for your video card and/or the libglut-dev package

Mac OS X 10.6 and above

  • X11 for OS X 10.6 and 10.7 should be installed by default, but should it not be there you can install it from your installation DVD, see: Mac Software Requirements).

  • For OS X 10.8 (Mountain Lion), X11 is not included but will need to be downloaded from the XQuartz project, you should use XQuartz version 2.7.2 or later.

  • XQuartz Note: If you have MATLAB installed on your computer, there might be an issue starting Continuity for the first time as the XQuartz configuration file needs to be modified to run Continuity. Please remove your $HOME/.xinitrc file and when you restart Continuity it will be recreated.

  • You will need the gcc compiler and build tools. If you do not already have a gcc compiler, you can install it and most of the required tools from the Terminal app (/Applications/Utilities) by typing xcode-select --install.
  • Lastly, you will need 'autoconf' to fully configure Continuity and you can get that by downloading/extracting and running

  • Revision 3764 and onward requires an Intel Processor.
  • Before revision 3764, a G3 or G4 was required.