Finite Strain in a 3D Block from Prescribed Displacements

Description

  • This example creates an undeformed two-element 3-D mesh, then deforms it and calculates stress and strain distributions.
  • The mesh is a simple block with trilinear Lagrange elements. The deformed nodal coordinates are completely specified so no boundary value problem is solved.
  • The Output Variables folder in the Constitutive Model Editor contains the equations for the kinematics and stresses that are rendered and listed. An example of the rendered strains is shown below:

Start Continuity

  • Launch the Continuity Client
  • On the About Continuity startup screen

    • Leave the mesh checkbox checked under Use Modules:

    • In addition, check the biomechanics checkbox

  • Click OK to bring up the main window

Create Mesh

  • Mesh→Edit→Coordinates...

    • Select rectangular Cartesian in the Global Coordinates: pop-up menu

    • Click OK to submit Coordinate Form

  • Mesh→Edit→Material Coordinates...

    • select the variable named dY_dMatl

    • In the field under Equation:, type dY_dMatl = eye(3)

    • This defines the transformation from global Cartesian coordinates to local material coordinates to simply be the identity matrix
    • The SymPy tutorial demonstrates how to define a matrix in SymPy

    • Select Compile... and click Compile Code as: C Double Precision

    • After the notice for a successful compilation, click the OK button to submit the material coordinates model

  • Mesh→Edit→Basis...

    • Choose Lagrange Basis Function→3D→Linear-Linear-Linear with 3 integration/collocation points for Xi 1, Xi 2, and Xi 3

    • Click Add

    • Verify that the list of basis functions now contains:
      • Linear-Linear-Linear Lagrange 3*3*3
      • Linear-Linear Lagrange 3*3
    • Click OK to submit Basis Form

  • Mesh→Edit→Nodes...

    • Confirm that Linear-Linear-Linear Lagrange 3*3*3 is already selected for you under Coordinate 1, Coordinate 2, and Coordinate 3

    • Use the Insert Node button in the left panel to create 11 additional nodes for a total of 12

    • In the Value fields next to Coordinate 1, Coordinate 2, and Coordinate 3 enter the following (X,Y,Z) nodal coordinates:

      • Node 1:

        (0., 0., 0.)

        Node 2:

        (1., 0., 0.)

        Node 3:

        (2., 0., 0.)

        Node 4:

        (0., 1., 0.)

        Node 5:

        (1., 1., 0.)

        Node 6:

        (2., 1., 0.)

        Node 7:

        (0., 0., 0.5)

        Node 8:

        (1., 0., 0.5)

        Node 9:

        (2., 0., 0.5)

        Node 10:

        (0., 1., 0.5)

        Node 11:

        (1., 1., 0.5)

        Node 12:

        (2., 1., 0.5)

    • Enable Field variable 1 by selecting the Field Vector 1 tab and choosing Linear-Linear-Linear Lagrange 3*3*3 from its Select Basis Number menu.

    • Click OK to submit Node Form

  • Mesh→Edit→Elements...

    • Element 1 consists of global nodes

1

2

4

5

7

8

10

11

  • Enter these numbers in the Global Node Numbers boxes. Use the tab key to change the input focus to the next box. Note that the order that global node numbers are entered determines the local Xi coordinate directions in the element, as illustrated by the graphic in the input form.

  • Use the Insert Element button in the left panel to create another element

  • The global nodes of element 2 are

2

3

5

6

8

9

11

12

  • enter them into the Global Node Numbers box

  • Click OK to submit Element Form

Render the Mesh

  • Mesh→Render→Elements... or click on

    • Click the lines radio button

    • Click Render to display mesh

      • The mesh should look like the screenshot below. (Use the mouse to rotate, pan and zoom the view)

  • File→Save→Model or click on

    • Specify a filename to save the model in. The file will be saved as filename.cont6

Create a Deformed 3-D Bilinear Mesh

  • If the Biomechanics menu is not loaded, select File→Load Continuity Modules... or click on

    • Select biomechanics and click OK

    • The menu bar should now show the Biomechanics command
  • Biomechanics→Update→Initial conditions with undeformed nodes

  • Biomechanics→Edit→Boundary Conditions...

    • On the Initial Conditions tab, edit Deformed Coordinate 2 of nodes 2 and 8 to change their values to -0.5

    • On the Initial Conditions tab, edit Deformed Coordinate 2 of nodes 5 and 11 to change their values to 1.5

    • Click the OK button

  • Biomechanics→Edit→Constitutive Model...

    • Right-click on the variable dy_dx in the left panel of the Edit Equations tab

      • Select Insert variable here...

      • Select the newly created variable and on the right panel
        • change its name: to F and press Enter

        • change its Description to something like Deformation Gradient Tensor wrt Material Coordinates

        • change its Type: to symbolic variable in the pop-up menu

        • in the Equation: field enter: F = dY_dMatl.T*dy_dx*dx_dMatl

          • This is a matrix multiplication. .T refers to transpose.
        • in the left side panel, drag the new variable F to be after dy_dx and before stress

    • Similarly create another symbolic variable after F named C with description Right Cauchy Green Deformation Tensor

      • For the Equation: enter C = F.T*F

    • Similarly create another symbolic variable after C named E with description Lagrangian Green's Strains wrt Material Coordinates

      • For the Equation: enter E = 0.5*(C-eye(3))

    • For the equation for the stress variable we will use as a placeholder for now: stress = eye(3)

    • Finally create an evaluated variable after stress named Eout with description Lagrangian Green's Strains wrt Material Coordinates

      • For the Equation: enter Eout = E

    • Select Compile... and click Compile Code as: C Double Precision

    • After the notice for a successful compilation, select the OK button to submit the constitutive model

  • File→Send or click on

    • If the Dimensions Form appears, simply click Apply Marked Recommendations and then OK

  • Mesh→Calculate Mesh... or click on

    • Click the OK button

  • File→Save→Model or click on

    • If your constitutive model compiled successfully, this is a good time to save your model again
  • Mesh→Render→Elements... or click on

    • Click the lines radio button

    • This time select the deformed radio button is selected

    • Click Render to display mesh lines

  • View→Show→OpenMesh... or click on

    • Click on 2. element lines2 in the list on the left, and enter 1,0,0 in the R,G,B entry field. Press [return] and close the window

    • You should see the undeformed mesh in blue and the deformed mesh in red as shown below.

Calculate Strains

  • Biomechanics→List Stress and Strain...

    • Note that the Output Variables are calculated using the equations entered in the Output Variable folder of the submitted Constitutive model

    • Click OK to display a listing of the selected Output Variables in the Table Manager

  • Biomechanics→Render Surface...

    • Next to At Xi 3 Location enter 0.5 (this chooses the midplane of the elements in the Xi3 (here Z) direction where results will be rendered)

    • Check the 'deformed radio button to render the solution deformed geometry

    • Select E-out - Lagrangian Green's Strain from the Variables menu. Since strain is a tensor variable, a choice of components will be presented. Select [1,1]. Output will be determined by equations in the Output Variables folder of the Constitutive Model Editor

    • Click OK to create a color-coded surface rendering of the E_yy_ component of the Lagrangian Strain

    • The result should look like the screenshot below
  • View→Show→OpenMesh... or click on

    • Click on the last Textured Field entry in the list

    • Click on the Colors tab

    • Note the range of the strains corresponding to the minimum (blue) and the maximum (red). You can change these to round numbers like 0.0 and 1.3 respectively.

    • Press the return key and close the Open Mesh Controls window

Pre-built model

  • File→Library→Search...

  • A pre-built model for this tutorial is available on Continuity's public database.
    • Title: bm_3D_block_strain

    • ID: 1385

  • Note that the material coordinate model and constitutive model may still need to be compiled.