Passive Sphere Inflation Model

Description

  • This tutorial will guide you through creating a model of the passive inflation of a sphere in order to roughly estimate the pressure-volume relationships in a frog heart.
  • In order to do this, you will be using the Mesh and Biomechanics modules of Continuity which essentially create the geometry and solve the constitutive equations, respectively.
  • The mesh begins as a simple two element semicircle, but is refined to have three transmural elements to increase the accuracy of the solver used in the Biomechanics module.
  • In the Biomechanics module, you will be picking a constitutive equation to represent the heart, and then if necessary adjust the proper variables to simulate experimental results.

Start Continuity

  • Launch the Continuity Client
  • On the About Continuity startup screen

    • Leave the Mesh checkbox checked under Use Modules:

  • File→Save→Model...

    • Enter passive.cont6 next to File Name:

    • Make sure to save model often in case of a program crash.
  • Click OK to bring up the main window

Create Mesh

  • Mesh→Edit→Coordinates...

    • Select spherical poiar in the Global Coordinates: pop-up menu. This coordinate system consists of a variable r (the radius), theta (to rotate in the (x,y) direction in a Cartesian system), and phi (to rotate in the z direction).

    • Click OK to submit Coordinate Form.

  • Mesh→Edit→Basis...

    • Choose Hermite Basis Function→3D→Linear-Linear-Cubic

    • Click Add Linear-Linear-Cubic

    • Ensure that the list contains in this order:
      • Linear-Linear-Cubic Hermite 3*3*3
        • Linear-Linear-Lagrange 3*3
        • Linear-Cubic Hermite 3*3
        • Cubic-Linear Hermite 3*3
    • Select Linear-Linear-Cubic Hermite 3*3*3 in the list, then click OK in the form.

  • Mesh→Edit→Nodes...

    • Ensure that under the drop down menus for Coordinate 1, Coordinate 2, and Coordinate 3, that Linear-Linear-Cubic Hermite 3*3*3 is selected. If not, adjust to reflect the correct basis function.

    • Click insert node five times to show nodes 1-6 in the list.

    • As the spherical polar coordinate system is selected, nodes will be defined in this fashion using r, theta, and phi. Theta will not be adjusted in this tutorial to keep the mesh fully on one plane. Coordinate 1 represents the r coordinateCoordinate 2 represents thetaand Coordinate 3 represents phi. Thus we will assign values as in the table below.

Nodes

Coordinate 1

Coordinate 2

Coordinate 3

1

Value

0.31

0.0

-90.0°

Wrt s(3)

1.0

0.0

0.0

2

Value

0.31

0.0

90.0°

Wrt s(3)

1.0

0.0

0.0

3

Value

0.51

0.0

-90.0°

Wrt s(3)

1.0

0.0

0.0

4

Value

0.51

0.0

90.0°

Wrt s(3)

1.0

0.0

0.0

5

Value

0.31

0.0

0.0°

Wrt s(3)

1.0

0.0

0.0

6

Value

0.51

0.0

0.0°

Wrt s(3)

1.0

0.0

0.0

  • Ensure that under Coordinate Options that the degrees radio button is selected.

  • Click OK under Submit Changes.

  • Mesh→Edit→Elements...

    • Select Insert Element until elements 1,2 are in the list.

    • Select Element 1 in the list by highlighting its 1 in the list.

    • In the Enter Global Node Numbers boxes, enter:

      •  1     1     5     5     3     3     6     6
    • For Element 2 enter:

      •  5     5     2     2     6     6     4     4
    • Click OK under Submit Changes.

    • The nodes will be connected in the order entered in these fields.
  • File→Send...

  • Check View→Edit Dimensions... to make sure there are no errors, hit 'Apply Marked Recommendations' if there are errors
  • Mesh→Calculate Mesh...

    • Under Calculate click OK.

  • Mesh→Render→Nodes...

    • Click Render.

  • Mesh→Render→Elements...

    • Click the lines radio button.

    • Click Render.

  • The mesh should now look like the first screenshot. It may be necessary to rotate (button in on bottom left toolbar) the model to get a better view. You may also zoom to get a better look. If your model does not render correctly, ensure that all of the values in the above steps have been inputted correctly.

Refine Mesh

  • Mesh→Refine...

    • In New Element Per Old Element In select 1 for xi1, 1 for xi2, and 3 for xi3.  

    • Click OK at bottom of form.

    • Refining the mesh in this way will create 3 elements across the wall, instead of just one as we had earlier.
  • Mesh→Edit→Nodes...

    • Ensure that there are now 12 nodes listed.
  • Mesh→Edit→Elements...

    • Ensure that there are now 6 elements listed
    • Under Element Label enter ENDO for ELEMENT 1. Hit ENTER on the keyboard to register change in label.

    • For elements 2-6, enter MID; EPI, ENDO; MID; EPI, respectively.

    • Ensure that each element has its proper label by clicking on it in the list.
  • File→Send...

  • Mesh→Calculate Mesh...

    • Under Calculate click OK.

  • Mesh→List→Volume...

    • Under Element List select ENDO.

    • Under Wall select LV Endocardium.

    • Click Insert Surfaces button.

    • Click OK.

  • Mesh→Render→Elements...

    • Click the lines radio button.

    • Click Render.

  • The model should now look similar to the second screenshot.
  • Mesh→Render→Elements...

    • This time select the surfaces radio button.

    • Click Render.

  • The model should now look similar to the third screenshot.

Add biomechanics data

  • Load the required biomechanics model from the database
    • File→Library→Search...
    • In the window near the top, enter 'lagrangian' and hit return.

    • From the listed models select BM_TI_of_Lagrangian_strains_comp_sympy by right-clicking on it and selecting 'Load'

    • When the warning window display, select the third choice: 'Retain current problem but overwrite the following objects: [dims, renderer, matEquations]'
  • Biomechanics→Update→Initial Conditions with undeformed nodes

    • This command updates the biomechanics Boundary Conditions form with the values already inputted in the mesh nodes form.

Biomechanics: Set-Up

  • Biomechanics→Edit→Boundary Conditions...

    • Verify that all 12 nodes are listed, as well as the correct basis functions and values for each of the Deformed Coordinates.

    • Next click on the Deformed Coordinates 2 tab, and insert all 12 nodes.

    • Repeat the process for the Deformed Coordinates 3 tab. Do not adjust the Deformed Coordinates 1 tab.

    • These steps ensure that there are no translations or rotations of the sphere, ensuring that only transmural inflation is possible.
    • Next click the External Pressure tab.

      • Under Element Number select ENDO for element 1.

    • Select ENDO in the list.
    • Under Select Pressure Type select Circulatory Model.

    • For the Inner Radius select LV Endocardium.

    • Click OK under Submit Changes.

  • Biomechanics→Edit→Circulation Model...

    • Select Linear Increase In Pressure for LV Only. Click OK.

    • Select System Circulation tab.

    • Enter value of 0.4 in field. This is the value that the pressure will be incremented by at each time step, in kPa.

    • Click OK button.

Biomechanics: Solve

  • File→Send...

  • Check View→Edit Dimensions... to make sure there are no errors, hit 'Apply Marked Recommendations' if there are errors
  • Mesh→Edit→Material Coordinates...

    • Click OK

  • Mesh→Calculate Mesh...

    • Under Calculate click OK.

  • Biomechanics→Solve Nonlinear...

    • Change Number of Steps to 15.

    • Under Solve or Close Form click Solve.

    • Wait for solver to finish. This may take some time.
  • The output files from this solve can be found in C:\Documents and Settings\Your Directory\.continuity\working\hemodata.xls

  • The values of the "hemodata" output file read in excel read as follows:

A

B

C

D

E

F

Initial Time

Current Time

Null

Current Pressure (kPa)

Current Volume (mL)

Volume from Previous Time Step (mL)

  • If you receive a "Server Error," or an "Attribute Error," make sure to save your work and reset the Continuity program. This error is actually a program crash. If this is not done, the program will likely continue to crash despite the proper adjustments being made in the model.

Visualize Inflation

  • To visualize the inflated sphere...
  • Mesh→Render→Elements...

    • Select the surfaces radio button.

    • Selected the deformed radio button this time.

    • Click the render button.

    • You should now see the inflated model, as in the last screenshot. The change is small, yet noticeable.

Pre-built Model

  • To use the pre-built model, download the following .cont6 file and load in Continuity 6.4.
  • Passive_Sphere01