Passive Cube Refined

Description

  • This example guides you through setting up and running a physical and material nonlinear bi-axial stretch test of a passive (non-contracting) cube using displacement boundary conditions.
  • The mesh is a simple one-element cube with tri-linear basis functions subdivided twice in each direction to yield eight elements. The boundary conditions assure that all rigid body motions are suppressed, and that the cube is stretched in two perpendicular directions. The material chosen is a transversely isotropic exponential strain energy function. The defaulted material properties are then adjusted to make the material isotropic.
  • Experiment with changing the geometry, boundary conditions, material parameters and fiber orientations.

Start Continuity

  • Launch the Continuity Client
  • On the About Continuity startup screen

    • Leave the mesh checkbox checked under Use Modules:

    • In addition, check the biomechanics checkbox

  • Click OK to bring up the main window

Create mesh

Refine mesh

  • Mesh→Refine...

    • Verify that 2 is entered for xi1, 2 for xi2, and 2 for xi3 under New Element per old element in

    • Click OK to submit

  • File→Send

    • If the Dimensions Form appears, simply click Apply Marked Recommendations and then OK

  • Mesh→Calculate Mesh...

  • Mesh→Render→Elements...

    • Click the lines radio button

    • Click Render to display mesh lines

  • The mesh should now look like the second screenshot

Add biomechanics data

  • Load the required biomechanics model from the database
    • File→Library→Search...
    • In the window near the top, enter 'lagrangian' and hit return.

    • From the listed models select BM_TI_of_Lagrangian_strains_comp_sympy by right-clicking on it and selecting 'Load'

    • When the warning window display, select the third choice: 'Retain current problem but overwrite the following objects: [dims, renderer, matEquations]'
  • Biomechanics→Update→Initial conditions with undeformed nodes

  • If the Biomechanics menu is not loaded, select File→Load Continuity Modules...

    • Select biomechanics and click OK

    • The menu bar should now show the Biomechanics command
  • Biomechanics→Edit→Constitutive Model...

    • Select TI_of_Lagrangian_strains_comp_sympy:Transversely isotropic exponential function of Lagrange Strains, slightly compressible(sympy)

    • Click on the Set Parameters tab (the second to last tab) and change the following values (making the material properties isotropic):

      • fiber_strain_coefficient = 6.0
      • transverse_strain_coefficient = 6.0
      • fiber_trans_shear_coefficient = 0.0
    • Click on the Submit tab (the very last tab) and then click the Submit button

  • Biomechanics→Update→Initial conditions with undeformed nodes

  • Biomechanics→Edit→Boundary Conditions...

    • Click on the Deformed Coorinates 1 tab

      • Click the Insert Nodes button two times

      • Click on node 1 in the list

        • Enter .*left.* in the Node(s) text field, and hit Enter

      • Click on node 2 in the list

        • Enter .*right.* in the Node(s) text field, and hit Enter

        • Enter 0.25 in the Value text field

    • Click on the Deformed Coorinates 2 tab

      • Click the Insert Nodes button two times

      • Click on node 1 in the list

        • Enter .*bottom.* in the Node(s) text field, and hit Enter

      • Click on node 2 in the list

        • Enter .*top.* in the Node(s) text field, and hit Enter

        • Enter 0.25 in the Value text field

    • Click on the Deformed Coorinates 3 tab

      • Click the Insert Nodes button 1 time

      • Click on node 1 in the list

        • Enter .*back.* in the Node(s) text field, and hit Enter

    • Click the OK button

  • File→Send

  • Check View→Edit Dimensions... to make sure there are no errors, hit 'Apply Marked Recommendations' if there are errors
  • Mesh→Calculate Mesh...

  • Biomechanics→Solve Nonlinear...

    • For Time Step, enter 0.0625

    • For Number of Steps, enter 16

    • For when number of iterations >, enter 150

    • Click the Solve button, and wait for the solver to finish its job

  • Mesh→Render→Elements...

    • Click the lines radio button

    • This time select the deformed radio button is selected

    • Click Render to display mesh lines

  • The mesh should now look like the third screenshot

List Stresses and Strains

  • Biomechanics→List→Stress and Strain...

    • Click OK

    • To view the results as a table:
      • In the Continuity Viewer Select Format->Tab-Delimited.

      • In the Continuity Table Manager Select File->Save to save this into a text file (viewable in Excel)

    • Close the Continuity Table Manager and the Continuity Viewer when you are done viewing or saving results.

Render Stresses and Strains

  • Biomechanics→Render→Surface...

    • For At Xi, select 2

    • For Location, enter 0.5

    • Select the deformed radio button (instead of undeformed).

    • In Define Color Range Check Use User Specified Values and give Min as -0.4 and Max as 0.0

    • In Variables select N-Nominal Stress Tensor

    • Under Variable Components select [0,0]

    • Click OK

  • Biomechanics→Render→Surface...

    • For At Xi, select 1

    • For Location, enter 0.5

    • Select the deformed radio button (instead of undeformed).

    • In Define Color Range Check Use User Specified Values and give Min as 0.0 and Max as 15.0

    • In Variables select N-Nominal Stress Tensor

    • Under Variable Components select [1,0]

    • Click OK

    • The mesh should now look like the fourth screenshot

See Also

  • Refinement
  • Material Properties
  • Fibers
  • Boundary Conditions