Prefitting on Blender

Description

Here, you will fit the data to an existing mesh of 132 elements and 280 nodes (Initial_mesh_132.off). You can always use this template to fit with your data, as the resulting mesh should be changed and adapted to the geometry of the data. This mesh is already a tridemensional hexahedral cubic-Hermite mesh. You can do this prefitting with another existing bidmensional quadrilateral cubic-Hermite mesh of 108 elements and 129 nodes (Initial_mesh_108.off) that is simpler.

Tips and Tricks

  • It is recommended that Blender 2.49b is used for mesh fitting. The newer version is not compatible with the initial mesh file.
  • You can always save your mesh as .blend format in any step and your assigned materials will present when you load it again.
  • To rotate the plane, and thus to view around your mesh: middle click and move your mouse

  • To translate the plane to the left or right: Shift + middle click and move your mouse

  • To hide what is selected: click H

  • To hide everything but what is selected: click Shift + H

  • To unhide everything: click Alt + H

  • To select or unselect all: click A

  • To select a rectangular area: click B

  • To select an area that you draw: hold Ctrl + left click draw the wanted area.

  • To move a node around: right click and move mouse

  • To change from Edit mode to Object mode: press Tab

  • You can always play with the transparency of the materials for the data (or selecting materials and hiding them for the mesh) to isolate and see only one part of the material, for example to verify your fitting.

  • Also, to make one surface well aligned with another, you can change the surface from solid to wire, so you can see through the walls and see all the nodes from the structure you want.

Separate the mesh into 5 different materials

  • Here is a detailed video with all the steps and the buttons you should press (http://youtu.be/wreItpCgYKg). Following, a "conceptual" tutorial.

  • An updated tutorial with all steps is here: https://www.youtube.com/watch?v=OaWo6zRy8cc

  • File->import->.stl will import the segmentation (Segmentation.stl), which we will call from now the patient data

  • To reduce the size of you mesh your mesh, you need to remove doubles.
  • Create 5 materials (LV, RV, septum, myocardium, rest). This will allow you to isolate each material when you will fit the mesh with the data.
  • Select the surface you want for the myocardium, and assign it to the first material (for example red). Then hide it and and proceed with the next surface, for example the right ventricle.
  • When you select a surface, you want to go from the apex to the base only. So you have to define where the base it, before drawing the area to select a surface.
  • In the end, there is non-assigned material left, that should be deleted.

Fitting the mesh with the data

  • Again, here is a detailed video with all the steps and the buttons you should press (http://www.youtube.com/watch?v=DFuW9gGXOtw). Following, another "conceptual" tutorial.

  • When fitting the nodes to the data, remember that the general structure have to stay in a quadratic/rectangular shape. In three dimensions, we want cubic elements, all aligned.
  • With the topology of 132 elements, you can regularize the surface semi-automatically, which is not shown in the video. With the 108 elements mesh, you need to do it manually.
    • For the semi-automatically technique: split the area on the right, and select Scripts Window.

    • Scripts->Mesh->Mesh Improvement tools

    • Then, you select the surfaces that you want to align, and on Quand faces, you click Regularize surface with iterations around 30

Exporting the mesh and the data

  • Before exporting your geometry, make sure that the cursor is centered.
    • On Object Mode, View->View properties.

    • On 3D cursor the x,y,and z component has to be 0.
    • Object->Transform->Center cursor.

    • Object->Clear/apply->Apply scale / Rotation to Obdata.

132 elements mesh

  • Here you only need to export the new mesh.
    • Split the area and select the Scripts Window.

    • Scripts->Mesh->Mesh Improvement tools.

    • On Export: Hex-keys will give you the ellements, Conti Vertex will give you the nodes, and Tricubic Hermite (with iterations=3) will give you the scale factors.

108 elements mesh

  • Here you will need to export both the mesh and the data separately.
    • File->Export->DEC Object File Format (.off).