Left Ventricular Geometric Fit (simplified)

Description

  • These step-by-step instructions will guide you through fitting a more complicate data set in 3D space
  • The data set is obtained from 4 long-axis slices of left ventricle
  • Initial truncated elipsoidal geometry is created in order to fit with the data set
  • An automated script that runs this tutorial up to the point of changing to 3D is included in the Continuity installation: examples\data07\fittingLeftVentricle.py. To run it, click File→Scripts→Read script...

Start Continuity

Setup intial mesh

Fit prolate in lambda

  • Fitting→Fit Data

    • In the Cooridinates tab, select coord_1, coord_2, coord_3 for the three coordinates

    • In the Xi Projections tab, enter 1-343 for Data list and 1-16 for Use points in element list

    • In the Fitting Variables tab, deselect all three coordinates

    • Click the Fit button on the bottom

    • Go back to the Xi Projections tab. Enter 344-686 for Data list and 17-32 for Use points in element list

    • Go back to the Fitting Variables tab and againdeselect all three coordinates

    • Click the Fit button on the bottom again

    • In the Fitting Variables tab, select only Coordinate 1

    • Click the Fit button one more time

    • Close the window by click the X button

  • File→Send

  • Mesh→Calculate Mesh...

  • Mesh→Render→Elements...

    • Click the lines radio button

    • Click Render

  • View→Show Open Mesh...

    • Click on elements lines3 in the list on the left

    • Click on the Colors tab

    • Change the R,G,B color field to 1, 0, 0 to change the color to the brightest red and then hit Enter

    • The mesh should now look similar to the second screenshot

Convert to 3D

  • Mesh→Edit→Elements...

  • Mesh→Edit→Basis...

    • Remove the two basis functions currently in the list by selecting each and then clicking the Subtract button.

    • Choose Hermite Basis Function→3D→Cubic-Cubic-Linear

    • Click Add Cubic-Cubic-Linear

    • Choose Hermite Basis Function→3D→Cubic-Cubic-Cubic

    • Click Add Cubic-Cubic-Cubic

    • Choose Lagrange Basis Function→3D→Linear-Linear-Linear

    • Click Add Linear-Linear-Linear

    • Verify that the list of basis functions now contains:
      • Cubic-Cubic-Linear Hermite 3*3*3
      • Cubic-Cubic Hermite 3*3
      • Cubic-Linear Hermite 3*3
      • Linear-Cubic Hermite 3*3
      • Cubic-Cubic-Cubic Hermite 3*3*3
      • Linear-Linear-Linear Lagrange 3*3*3
      • Linear-Linear Lagrange 3*3
    • Click OK to submit Basis Form

  • Mesh→Edit→Nodes...

    • Select Cubic-Cubic-Linear under Coordinate 1

    • Select Linear-Linear-Linear under Coordinate 2 and Coordinate 3

    • Select Cubic-Cubic-Linear under Field Variable 1 in the Field Vector 1 tab

    • Click OK to submit Node Form

  • File→Send

  • Mesh→Calculate Mesh...

  • Mesh→Refine...

    • Enter 1 for xi1, 1 for xi2, and 1 for xi3 under New Element per old element in

    • Click OK to submit

  • Mesh→Edit→Nodes...

    • Select Cubic-Cubic-Cubic under Coordinate 1, Coordinate 2, and Coordinate 3

    • Select Cubic-Cubic-Cubic under Field Variable 1 in the Field Vector 1 tab

    • Click OK to submit Node Form

  • File→Send

  • Mesh→Calculate Mesh...

  • Mesh→Render→Elements...

    • Click lines radio button

    • Click Render to display mesh

  • View→Show Open Mesh...

    • Click on elements lines4 in the list on the left

    • Click on the Colors tab

    • Change the R,G,B color field to 0, 0.5, 0.5 to change the color to the brightest red and then hit Enter

    • Close the window by click the X button

  • The mesh should now look similar to the third screenshot

Pre-built model

This cont6 file contains all data and parameters for this problem prior to changing it to 3D: fit2_a.cont6 This cont6 file contains all data and parameters for this problem after changing to 3D: fit2_b.cont6 The model is also loaded into the Continuity database (ID: 1303) with run scripts in the script manager.