STICH Patient Data and the Continuity Library

Description

  • This example explains how to use the Continuity library (also referred to as the database) to share STICH patient data. These data were provided as text files, so the process of depositing and retrieving STICH data from the library requires a different procedure than the general tutorial.

  • To follow this example in detail, you must have Continuity installed on your machine. The steps below are based on data that can be found in the examples directory on your Continuity client in the data19 folder (.../continuity/pcty/examples/data19/). To access the library for the first time, please follow the steps in the general tutorial.

Start Continuity

  • Launch Continuity in Standalone (both Client and Server) mode and click OK on the startup screen.

Retrieving a STICH Model

First you will use the library to retrieve a model generated with STICH patient data.

  • File→Library→Search...

    • A Search Database form appears that contains a list of all models deposited to the library. You can enter a search term in the field at the top of the form, or manually scroll through the list. The buttons to the left of the search field are clickable, allowing you to initiate a highly specific search. For example, Title→Attributes→Model lets you search for models of a particular species, organ, or several other parameters.

    • Scroll through the list and click to highlight SZ_STUDY1_Mesh_0_ED. Click the (Open All Versions of Selected Model) button to bring up the Retrieve Form.

      • In this form you can view information related to each of the two versions of the model. The Objects tab lists all objects (e.g., attachments, scripts, etc.) associated with the selected version of the model, and lets you choose whether or not to retrieve them. For now, leave them at the default Retrieve. The contents of the other tabs will be discussed in more detail in the Depositing a New Version section of this example. You can also refer to the general tutorial.

      • Click to highlight 1 at the left of the form to choose Version 1 of the model, and click OK to load it into your Continuity program.

Manipulating the STICH Model

Now that the model is loaded in Continuity you can view its scripts and attachments, and run the set of scripts on the attachments to render the model.

  • File→Scripts→Script Manager... opens the Script Manager. You will see a list of Python scripts written to handle the text files contained in the data19 folder.

  • File→Attachments... opens the Attachment Manager. Two attachments (text files of data) have been deposited along with this model version: SZ_STUDY1_Mesh_Epi0_ED.txt and SZ_STUDY1_Mesh_Endo0_ED.txt.

  • To render the model, you must run the scripts. In the Script Manager, select all of the scripts and click Execute Selected. This will run the scripts on the two attachments. Watch the main window of Continuity to view progress; depending on the speed of your machine it can take up to a couple minutes for the scripts to finish running.

  • You can now view and edit data associated with the model, such as nodes (Mesh→Edit→Nodes...), material coordinates (Mesh→Edit→Material Coordinates...), basis functions (Mesh→Edit→Basis...), and the coordinate system (Mesh→Edit→Coordinates...). You can also perform a tensor transformation (Mesh→Edit→Tensor Transformation...). The Continuity website has other tutorials that describe the program's functionality beyond that presented here.

  • If you wish, you can save the model to your hard drive (File→Save→Model). This will not save the visualization. If you want to save the rendered view, choose File→Save→Visualization.

Depositing a New Version

Say you want to build a model and deposit it to the database using different data files than those attached to Version 1. You can do this easily by changing the attachments in the Attachment Manager and depositing the model as a new version. For the STICH datasets, a "model" deposited to the database currently consists of the set of scripts and attachments.

  • First you must reset Continuity if you still have a model loaded. Choose File→Reset... and click OK to accept the default Reset and lose all data for: option. Otherwise, the program will crash if you try to run the scripts on a new set of data.

  • Since you need to have a model loaded in Continuity in order to deposit a new version of that same model, you need to access it again. You must do this by retrieving the model from the database as discussed above if you wish to deposit a new version of the same model. If you load a saved model from your hard drive, the database recognizes that the file name is the same but is unable to deposit the new version.
  • Once you have the model loaded again, open the Attachment Manager.

    • Select one of the attachments and click Delete Selected to remove it. Repeat with the other attachment.

    • Click Insert Attachment, and newattachment0 will appear in the attachment list.

      • Click Import... and navigate to the data19 folder. Choose one of the Epi text files (the way the scripts are written, the order of attachments matters).

      • To give the attachment a more descriptive name, click Rename and enter a new name.

    • Click Insert Attachment again, and follow the previous steps to import an Endo text file and rename it.

    • In the Attachment Manager, click OK to finish editing the attachments. This step is essential.

  • You can now deposit the model and/or run the scripts on the new attachments in the same manner as before. It is not necessary to run the scripts before depositing the model.
    • If you do run the scripts, the SZ_STUDY1_Mesh_0_ED model you loaded will be cleared and you will only have the choice to deposit to the database as a new model with a different name. You must also re-import the attachments since these are cleared along with the model.
    • If you do not run the scripts, you retain the option to deposit a new version of the SZ_STUDY1_Mesh_0_ED model and do not have to import the attachments again.
  • To deposit the new model or new version, choose File→Library→Deposit...

    • In the Properties pane you can specify general information about the model or version. More detail is better! Based on what you have done with the model, you can choose what you think its curation standard is (see the general tutorial for more information on the different levels). You can also choose whether you want the model to be public or private.

    • The Objects pane allows you to see exactly what will be deposited as part of the model or version, and you have control over whether to deposit or leave out each individual object.

    • The Attributes pane is one of the most important features of the database. Here you can specify information about the data you are depositing, which is then aggregated into searchable metadata. First enter information about the model (species, organ system, etc.), then click the Model button and choose other components of the model to annotate.

    • The Links pane provides a place to add a link to a journal article, for example.

    • Finally, the Metadata tab provides a summary of information attached to the model.

  • To finalize model/version deposition, click OK.