Creating a Simple 2-D Bilinear Lagrange Mesh

Description

  • This example creates, saves and refines a simple 2D, two-element mesh with Bilinear Lagrange finite elements.

Basic Concepts

  • After completing the Mesh module tutorials 1 and 2, you should understand that:
    • Each node has one or more parameters associated with it, depending on the number of variables and the basis function type(s) chosen
    • Elements are defined by specifying connections between nodes
  • After completing this tutorial, you should understand:

    • How to make and refine two-dimensional tensor-product finite element meshes
  • Useful points to consider:
    • In practice, we do not typically type in nodal coordinates for real meshes. We can import nodes and elements from a tab delimited xls file using the import/export/graph button in the node and element editors.

Step-by-step Instructions

  • The following instructions will guide you in creating the 2D mesh pictured below.

Start Continuity

Create Mesh

  • Mesh→Edit→Coordinates...

    • Select rectangular Cartesian in the Global Coordinates: pop-up menu

    • Click OK to submit Coordinate Form

  • Mesh→Edit→Basis...

    • Choose Lagrange Basis Function→2D→Linear-Linear with 3 integration/collocation points for Xi 1, Xi 2, and Xi 3

    • Click Add

    • Click OK to submit Basis Form

  • Mesh→Edit→Nodes...

    • Confirm that Linear-Linear Lagrange 3*3 is already selected for you under Coordinate 1, Coordinate 2, and Coordinate 3

    • Use the Insert Node button in the left panel to create 5 additional nodes for a total of 6

    • In the Value fields next to Coordinate 1, Coordinate 2, and Coordinate 3 enter the following (X,Y,Z) nodal coordinates:

      • Node 1: (0., 0., 0.)
      • Node 2: (1., 0., 0.)
      • Node 3: (2., 0., 0.)
      • Node 4: (0., 1., 0.)
      • Node 5: (1., 1., 0.)
      • Node 6: (2., 1., 0.)
    • Click OK to submit Node Form

  • Mesh→Edit→Elements...

    • The element definition for element 1 is 1, 2, 4, 5, so enter this in the Global Node Numbers box

    • Use the Insert Element button in the left panel to create another element

    • The element definition for element 2 is 2, 3, 5, 6, so enter this in the Global Node Numbers box

    • Click OK to submit Element Form

  • File→Send

  • Mesh→Calculate Mesh...

Render the Mesh

Refine the mesh four-fold and re-render